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About the book
At a Glance

Document Scope This manual describes how to get started with the Vijeo Look software

User Comments We welcome your comments about this document. You can reach us by e-mail at
TECHCOMM@modicon.com
Vijeo Look 5
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Vijeo Look
1

General overview of Vijeo Look
Presentation of the Human Machine Interface (HMI)

General Vijeo Look is a HMI (Human Machine Interface) application. It is operated using
Windows 98, Windows ME, Windows NT4 SP6 and Windows 2000.
The minimum configuration required is a Celeron 566Mhz with 128 Mb of RAM.
Vijeo Look supplies all that is necessary for data acquisition, as well as for the
development and visualization of animated synoptics for running PC processes.
Real time data acquisition is performed using the OPC Factory Server (OFS)
communications server, included in the product.

Illustration using an automated line command:
Vijeo Look

Grid

Shades

Textures

Speed (ms)

Grid

Shade

Textures

0

100

200

300

400
500

Cars painted

Red

Blue

Green

Yellow

03

03

00

00

00

Configuration

Auto

Red

27/08/2001 08:54:52:550 Alarm on - not ack Device 1. Default01
27/08/2001 08:54:53:742 Alarm on - not ack Device 1. Default01

Administrator 1 Manufacturing 27/08/01 08:51:03

Configuration of the ani...
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General overview of Vijeo Look
Using a simple graphic object, it is possible to visualize and /or command a motor,
robot or other device by associating it with one or more variables.

The main features of the product are:
� an advanced graphic motor, comprising:

� libraries of graphic objects that may be configured by the user,
� editor of advanced native graphic elements,
� management of CAD type calques,
� unlimited synoptic size,
� 24 bit color support,
� import of images and animations in BMP, JPEG, GIF, AVI, EMF, and WMF

formats
� Zoom function,

� many types of animations,
� flexible configuration of user rights,
� activeX container,
� VBA motor,
� Java Bean container,
� real time data logging tool,
� interface available in English, French, German or Spanish.
8 VijeoLook



Vijeo Look
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Installing the product Vijeo Look
At a Glance

Subject of this
Chapter

The aim of this chapter is to describe how to install the different components of Vijeo
Look.

What's in this
Chapter?

This Chapter contains the following Maps:

Topic Page

Installation of Vijeo Look and its different components 10

Uninstalling Vijeo Look and its different components 13

License management 14

Vijeo Look Registration Request 16

Vijeo Look Upgrade Registration Request 17
9



Installing the product Vijeo Look
Installation of Vijeo Look and its different components

At a Glance The product is available in CD-ROM format including the installation of Vijeo Look
and OPC Factory Server, Visual Basic Application, Java virtual machine, MSDE,
LapLink Gold and the communications driver Uni-telway.

Illustration The figure below shows the welcome page of Vijeo Look Setup:

Note: Before performing a reinstallation, users are advised to perform a
deinstallation (See Uninstalling Vijeo Look and its different components, p. 13)

Vijeo Look 

< Previous Next > Cancel

Welcome to Vijeo Look Installshield Wizard.

The InstallShield Wizard will set up Vijeo Look on your
computer. To continue click on Next.
10 VijeoLook



Installing the product Vijeo Look
Installing the
product

To install Vijeo Look and its components, open the file Setup.exe
Description of the different installation stages:

Example using the setup of "LapLink driver":

1 Selecting the
installation language

Select the required setup language:
� German,
� English,
� Spanish,
� French (standard).

2 License contract If you accept the contract terms, go to the next page.

3 Client information To customize the software you must enter the following
information:
� User name,
� Company name.

4 Languages Select the two languages you wish to use as well as the one
to be used by default in the application

5 Setup type Select the setup type which best suits your needs:
� By default,
� Compact (with setup of the demonstration project or the

shared libraries),
� Customized (allows user to choose the target directory

as well as some options in the setup)

Vijeo Look 

< Previous Next > Cancel

Select the components
Choose the components that the setup assistant will install.

Select the components to be set up, and remove the components that are not to be installed.

Programs
Demonstration Projects
On line help

English

Description

This component enables
MSDE to be set up.

InstallShield

Space necessary in
Space available in

French
German
Spanish

Documentation

English
French

MSDE,

C: 90027 K
C: 434902 K
Vijeo Look 11



Installing the product Vijeo Look
Description of the different installation stages:

The installshield is installing Vijeo Look and the other components you have
selected.
The installshield installs OPC Factory Server by default, followed consecutively by
MSDE, Visual Basic Application, Vijeo Look, then Java Runtime and the Uni-telway
communication driver.

6 Select a program
folder

The setup assistant adds the program icons to the
chosen program folder (Modicon Telemecanique by
default). The assistant creates a "Modicon
Telemecanique" sub-folder by default, called "Vijeo
Look", in which all the tools associated with the product
can be found.

7 Launch installation Recheck the configuration of parameters before
launching the installation.

8 Installing the
Uni-telway driver

Once all the components of Vijeo Look have been
installed, the installshield will ask you to configure the
installation of the Uni-telway driver.

Note: When installation is complete, do not forget to restart your computer to
ensure all the installed components have been taken into account.
12 VijeoLook



Installing the product Vijeo Look
Uninstalling Vijeo Look and its different components

Description

To uninstall Vijeo Look and the other components, proceed as follows:
� uninstall, using the "Add/Remove programs" command in the "Control Panel", the

following programs:
� Java Runtime Environment,
� OFS Configuration tool,
� OPC Factory Server
� Uni-telway,
� XWAY,
� Vijeo Look,
� MSDE,
� Laplink (if set up).

� switch your machine on again.

Note: Before uninstalling Vijeo Look, it is vital to first transfer the software
protections to another computer (see Transferring protections, p. 15), otherwise
it will be no longer possible to continue using Vijeo Look.
Vijeo Look 13



Installing the product Vijeo Look
License management

Description When setting up Vijeo Look you have 21 days to request your license from
Schneider Automation.

During these 21 days the status of your software is "Unauthorized" and remains so
until entry of the permanent authorization code provided by Schneider Automation.

Reminder:
� once installed, it is necessary to obtain a definitive license,
� once this license has been obtained, it is possible to transfer the license to

another work station,
� if you purchase a later version of Vijeo Look, a simple update is all that is

necessary.

To obtain your
license

During the first launch of Vijeo Look, you are asked to enter the "serial number" and
"reference number" so that a work station may be identified in order to obtain your
license.
To obtain the permanent code of the software:

Note: Once the license has been obtained, it is possible to transfer the license to
another work station (see below).

Step Action

1 Enter the serial number and reference number, then click "Next". The
CopyControl program generates a setup code.

2 You can generate the demand file now or later.

3 Correctly fill in all the information requested, then click "Next".

4 Send this document by Fax or by E-mail to receive the permanent
authorization code.
14 VijeoLook



Installing the product Vijeo Look
Performing an
update.

There are 6 different packages for Vijeo Look:
� "buildtime/runtime" 128 I/O, for a single OFS server,
� "buildtime/runtime" 512 I/O, for a single OFS server,
� "buildtime/runtime" 1024 I/O, for all OPC servers,
� "runtime" 128 I/O, for a single OFS server,
� "runtime" 256 I/O, for a single OFS server,
� "runtime" 1024 I/O, for all OPC servers,

When you purchase Vijeo Look, you can ask for an update in order to have more I/
Os.
For this, you must purchase the corresponding commercial reference, then, on
receipt of the order, create a license demand as for a first purchase. For an update,
the definitive version will only be effective on receipt of the definitive code issued by
Schneider.

Transferring
protections

It is possible to set up Vijeo Look on several machines; however, once a protection
is transferred, Vijeo Look will only be active on the machine possessing the software
protections.

It is therefore possible to transfer a protection from one machine to another as
follows (example of a transfer from machine A, in which the permanent authorization
code is found, to machine B):
� after setup on machine B, note the generated code,
� on machine A, click "Protection transfer" in the main menu,
� enter and confirm the setup code of machine B,
� click "Recover the authorization code" to validate the transfer, the license of

machine A is rendered invalid and a new code is generated for machine B.
Vijeo Look 15



Installing the product Vijeo Look
Vijeo Look Registration Request

Information DATE:

-----------------------------------

SERIAL NUMBER:

REFERENCE NUMBER:

INSTALLATION CODE:

UPDATE NUMBER:

-----------------------------------

COMPANY NAME :

CONTACT NAME :

ADDRESS :

CITY :

ZIP CODE :

STATE :

COUNTRY :

EMAIL :

PHONE :

FAX :

[ Stick the product label here ]
16 VijeoLook



Installing the product Vijeo Look
Vijeo Look Upgrade Registration Request

Information DATE:

-----------------------------------

SERIAL NUMBER:

REFERENCE NUMBER:

INSTALLATION CODE:

UPDATE NUMBER:

-----------------------------------

COMPANY NAME :

CONTACT NAME :

ADDRESS :

CITY :

ZIP CODE :

STATE :

COUNTRY :

EMAIL :

PHONE :

FAX :

-----------------------------------

PREVIOUS SERIAL NUMBER :

PREVIOUS REFERENCE NUMBER :

[ Stick the product label here ]
Vijeo Look 17
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Main functions of Vijeo Look
At a Glance

Subject of this
Chapter

This chapter describes the main functions available in the synoptics of Vijeo Look.

What's in this
Chapter?

This Chapter contains the following Maps:

Topic Page

The main tools of Vijeo Look 20

Description of the main functions of the "Insert" menu 22

Description of the main functions of the "Tools/Application/Configuration
Explorer" menu

24
19



Functions of Vijeo Look
The main tools of Vijeo Look

At a Glance The main tools of Vijeo Look are concentrated on the Visual Basic software
application, the ActiveX and Beans Components, trend curves, viewers and data
bases.
Description of the main tools:

Menu Submenu Description

Display Visual Basic editor This link with Visual Basic is used to develop
scripts.

Insert ActiveX Control Allows ActiveX controls to be inserted in a
synoptic.
It should be noted that the ActiveX controls
shown in this field must be pre-selected in the
menu (see Tools/Ergonomics/ActiveX Controls).

Insert Bean component Allows a Bean component to be inserted in a
synoptic.
Unlike the ActiveX Controls, all Bean
components shown in the Project are displayed
without pre-selection.

Insert Trend curves Enable analog data to be visualized in trend
curve form.

Insert Alarm window Displays the status of alarms in real time.

Insert Log window Displays archived data.

Draw Allows synoptics to be drawn using native
graphic elements.

Animation Allows the graphic elements of a synoptic to be
animated according to real time variables.

Tools Application � access to the OFS configuration via the
configuration tool,

� access to the Vijeo Look configuration tool
(configuration tool of the log server, data
server, etc.).

File Edit Display Insert Drawing Order Animation Mode Tools Window ?

Display

Insert

Insert

Insert

Insert

Insert

Draw

Animation

Tools
20 VijeoLook



Functions of Vijeo Look
Tools Project Enables an existing project to be opened, a new
project to be created and to restore/archive a
project.

Menu Submenu Description

Tools
Vijeo Look 21



Functions of Vijeo Look
Description of the main functions of the "Insert" menu

ActiveX The ActiveX are objects that can be easily programmed using Visual Basic for
Application. You can for example insert the ActiveX "Microsoft Web Browser" in
order to display an HTML page (see Example of inserting an ActiveX, p. 40).

Bean component Bean components are objects (like the ActiveX) used to send back data supplied by
PLC variables (see Example of inserting a Bean component, p. 41).
We can for example display the rotation value of a motor using an analog measuring
device.
Some examples of Bean Components:

Trend curves The trend curve is used to display in graphic form the evolution over time of one or
more variables. Several trend curves can be concatenated in a synoptic, the only
limitation being the size of the physical space available.
It is also possible to insert several "Trend curve" windows into the same synoptic.
Illustration:

Measurement devices Switch

14:13:20 14:13:30 14:13:40 14
22 VijeoLook



Functions of Vijeo Look
The main characteristics of the trend curves are:
� up to eight registers and/or bits can be displayed for each log,
� Log and Real Time modes,
� the coordinate axis (amplitude) is configurable for each "Trend curve" window,
� the abscissa axis (time) is configurable between 1 second and 32767 days,
� zoom functions,
� an unlimited number of log displays per project.

Alarm window The alarm Viewer is an ActiveX that displays the status of the alarms. Several alarm
Viewers can be created in the one synoptic, the only limitation being the size of the
physical space available.
Illustration:

The main characteristics of the alarm Viewers are:
� an unlimited number of alarm Viewers in each project,
� the format of the alarm text is totally configurable.

Log window The Log Viewer is an ActiveX control which displays the data saved in the data base.
It is possible to display all the data or, by using filters, to display only a part of the
data. Several Log Viewers can be inserted into a synoptic, the only limitation being
the size of the physical space available.

The main characteristics of the Log Viewer are:
� an unlimited number of Log Viewers for each project,
� for each Log Viewer, one or more filters can be created,
� Display:

� change in an alarm's status,
� change in a bit's status,
� change in a word's value.

Date Hour Title Name
24/08/01 10:36:25:532 Alarm on - not ack Device1.Default01
24/08/01 10:36:25:532 Alarm on - not ack Device1.Default01
Vijeo Look 23



Functions of Vijeo Look
Description of the main functions of the "Tools/Application/Configuration
Explorer" menu

General Certain "Configuration explorer" tabs appear only if the "Advanced parameters"
option is selected from the "Display" menu of "Configuration explorer".

General
parameters

Using the general parameters, we can configure:
� the filters,
� the association of tags,
� the properties of variables,
� the property ranges of variables,

Log server The log data server collects and saves data in real time from the Real Time Data
Server. The trend and log viewers display the logged data.

This version of the software is qualified to use the following standard data bases:
� Access 2000,
� MSDE (Microsoft Data Exchange).

Data server The data server is used to create and to set up the variables (bit, register, text) to be
used in synoptics and/or archived.
It is also used to enhance the properties of variables by adding user parameters.
Illustration:

Configuration Explorer

General parameters
Log server
Data server

OPC server

File Display

Variables
OFS

Name

Variable Properties Verbose properties

Associated label

Type

Internal

External

Server name

Type of Data Type

Trend

HMI accessAlarm

Logging

Options

Ready
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Reminder about the OFS
configuration tool
Reminder about editing aliases

Definition An alias is a variable used by OFS whose properties include a name, a
communication protocol and a table of symbols file (this last property being
optional).

Creating an alias Aliases are edited using the OFS configuration tool, named "OFSconf.exa", which is
found in: ...\Ofs\OFSconf\OFSconf.exe.
The OFS Configuration Tool main window shows the aliases listed in a grid, the
"Server Mode" option and the "Group Min Update Rate". This data covers most
user requirements.

Note: Vijeo Look is preconfigured with OFS. Several aliases have been created for
the operation of the demonstration project.
25



Reminder about creating aliases
Illustration:

The table below describes the fields of the above screen:

OFS Configuration 

Welcome to the OPC Factory Server Configuration tool

200

2 11/10/01

Properties of
ms

Group Min Update Rate

Server mode
Hidden
Control
Diagnostic
Verbose Diag.

List of PLC aliases

Building

Device1

Device2

Device3

UNTLW01:1.2.0

UNTLW01:0.254.0

UNTLW01:1.3.0

MBT:1.2.3.4

Name <driver>:<PLC Addr> Symbols table file

Server Edit ?Print

???

Advanced...

aliases 

Number of aliases: 8

4

Ok Cancel Apply

Food_Beverage UNTLW01:1.4.0

Alias

Description

C:\Program Files\Modicon Telemecanique\Vijeo Look\Projects\Demo\OFS Files\Building.csv

Machines
Manufacturing

WaterPlant

UNTLW01:1.50
UNTLW01:1.6.0

UNTLW01:1.7.0

C:\Program Files\Modicon Telemecanique\Vijeo Look\Projects\Demo\OFS Files\Device1.csv
C:\Program Files\Modicon Telemecanique\Vijeo Look\Projects\Demo\OFS Files\Device2.csv

C:\Program Files\Modicon Telemecanique\Vijeo Look\Projects\Demo\OFS Files\Device3.csv

C:\Program Files\Modicon Telemecanique\Vijeo Look\Projects\Demo\OFS Files\Food_Beverage.csv

C:\Program Files\Modicon Telemecanique\Vijeo Look\Projects\Demo\OFS Files\Machines.csv
C:\Program Files\Modicon Telemecanique\Vijeo Look\Projects\Demo\OFS Files\Manufacturing.csv

C:\Program Files\Modicon Telemecanique\Vijeo Look\Projects\Demo\OFS Files\WaterPlant.csv

C:\Program Files\Modicon Telemecanique\OFS\Server\Ofs.exe

Server mode Hidden: the server is invisible on screen.
Control: the server is iconized but only the system menu is accessible (right
mouse click).
Diag. : a complete set of diagnostics windows is displayed during server
execution, including a plotting window displaying warning and/or error
messages.
Verbose diag.: the plotting window displays detailed information messages
in addition to errors and warnings. The rest is identical to "Diag." mode.

Group Min
Update Rate

Minimum update rate allowed for groups. The update rate should be set by
the client as a multiple of this value. Numerical value in ms. Range:
[10..32767]

"Advanced"
button

Display seven additional tabs for experienced users.

Site name Here the user may enter up to 50 characters of text in order to identify the
configuration of the aliases entered.
This text appears at the top of the print file. If you make a back-up copy, it is
saved in the chosen file. It does not figure in the configuration of the OFS
server.

OK Configuration validation and exiting the Configuration tool.
26 VijeoLook



Reminder about creating aliases
The aliases grid is made up of 3 columns which contain the most important
information on each device.

Creating an alias involves:
� assigning a name,
� defining the network address of the device, which includes the network driver and

the device address,
� Providing a Symbols table file name (optional),
� setting the alias properties which are related to how the server will behave

towards the variables created on that alias.
These operations are all accessible via click-sensitive areas in the grid and the
"Alias properties" button.

Sort function in the grid:

Apply Configuration validation without exiting the Configuration Tool.

Cancel Canceling modifications made since the Configuration tool was launched or
since the "Apply" button was activated.
A confirmation request message is displayed.

Note: The information on the number of aliases declared is displayed. The "Create
new alias" and "Clear current alias" buttons allow an alias to be added to the grid
and the selected alias to be deleted.

Note: Once an alias has been created, it is necessary to close and then reopen the
OFS server to integrate any modifications made using the configuration tool.

CAUTION

Using the aliases

A device should be associated with a single and unique alias. If two
aliases point to the same device and are used simultaneously, the
communication will malfunction. The properties will be the same for
both, and set to the properties of the alias first used to create an item.
In the same way, using an alias and accessing the same device directly
from the address will have similar results.

Failure to observe this precaution can result in injury or
equipment damage.
Vijeo Look 27



Reminder about creating aliases
The aliases can be arranged in the grid according to the parameters associated with
the alias:
� Name of alias, driver, symbols table file. Simply click on the upper strip of the grid

in the appropriate column. Arrangement in alphabetical order.
� Other parameters: activate the "Edit ->Sort" menu and select the parameter you

want. They are arranged alternately in increasing, or (by clicking again)
decreasing order of values (e.g.: for a binary value parameter, increasing
signifies all the aliases with the value 0, then all those with the value 1).

Symbols table
file

A symbols table file can be associated with the alias, in order to provide access to
the symbols for the variables of this device. The symbols file is generated by the PLC
programming software, e.g. PL7 for Premium/Micro or Concept for Quantum.
Clicking in the "Symbols table file" area for the selected alias in the grid brings up a
file explorer:
The file types that can be inserted are listed in the "type of files" list box. Select the
appropriate file type.
Enter the file of your choice and click "Open". The file name and directory will then
be displayed in the grid.
28 VijeoLook
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Start-up
At a Glance

Subject of this
Chapter

The aim of this chapter is to help you with the realization of your projects. We shall
explain with the use of concrete examples how some of the demonstration project
blocks (delivered with the product) were created.

What's in this
Chapter?

This Chapter contains the following Maps:

Topic Page

Creating a project 30

Detailed explanations of some parts of the demonstration project 31

Creating part of the "manufacture" synoptic 32

Creating part of the "purification" synoptic 35

Inserting an ActiveX and a Bean component 40

Writing a variable 42
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Start-up
Creating a project

Description The following table describes the procedure to be followed to create, launch, and
archive your project:

Step Action

1 Before launching Vijeo Look, it is necessary to create all the aliases (See
Reminder about editing aliases, p. 25) of your project with the OFS configuration
tool,
� assign a name,
� choose a network (MODBUS+, Uni-telway, etc.)
� validate.
If you have a symbol table (See Symbols table file, p. 28)file from PL7 or another
software, you can assign it to the alias.

2 Once the alias has been created, it is necessary to configure and activate the
communication driver (the Uni-telway driver is provided with the product).

3 Launch Vijeo Look.

4 In the "File" menu, click on "New". The window "New synoptic" will then be
displayed. Click on OK to access your project.

5 In the "Tools" menu, click on "Application" then "Explorer configuration tool" to
configure all your variables , alarms and logs.

6 You are now in Vijeo Look "Edit" mode: you can now create your synoptics.

7 Once your synoptic has been created, select "Execution" mode from the "Mode"
menu to test it.

8 You can archive your project by clicking on the "Tool" menu, then "Project", and
finally "Archive/Restore".
30 VijeoLook



Start-up
Detailed explanations of some parts of the demonstration project

Description The Vijeo Look demonstration project is made up of 5 parts:
� manufacturing,
� purification,
� complex machines,
� agri-food
� construction.
Illustration:

In each synoptic there are buttons providing you with explanations on the creation 
of an animation or an object.

On the following pages you will find explanations which complete those associated
   of certain parts of the "demo".

File Edit Display Insert Drawing Order Animation Mode Tools Window ?
Vijeo Look
Vijeo Look 31



Start-up
Creating part of the "manufacture" synoptic

General
Description

In this demonstration project we can find two buttons (Alt + F1) that explain:
� the creation of the tanks (button 1),
� the creation of the painted cars counter (button 2).
Illustration of the example:

Description of
the "tank" part

This tank along with the bar-chart is composed of two grouped objects:
� an image (bitmap),
� a rectangle.

Inserting an
image

To insert an image proceed as follows:

Note: To find out about the properties of a graphic object it is necessary to switch
to "Edit" mode, then right click and select "Properties ...".

Cars painted

Red

Blue

Green

Yellow

Button 1 Button 2

Step Action

1 � Before launching Vijeo Look:
� copy all your images (only bmp, jpeg, gif, avi, emf, and wmf) into c:\Program

Files\Modicon Telemecanique\Vijeo Look\Projects\"project name"\Bitmap
Files,

� launch Vijeo Look.
� in Vijeo Look, other predefined images can also be inserted by clicking "Tool",

then "Project" and "Libraries".

2 In the "File" menu, click "New". The window "New synoptic" will then be displayed.
Click on OK to access your project.

3 In the "Insert" menu click "Image" then select and validate. The image is inserted.
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Creating a bar
chart

To create a rectangle showing the level of the tank, proceed as follows:

Description of
the counter part

We can the change the value of an object using the mathematical operator "=". Here
we add 4 internal variables, which correspond to the number of cars painted per
color.

Creating a
counter

To create a counter showing the number of cars painted red (for example), proceed
as follows:

Step Action

1 Before launching Vijeo Look:
� create an alias (give a name, and define the network type) in the OFS

configuration tool (see Reminder about editing aliases, p. 25), then validate,
� launch Vijeo Look.

2 In the "File" menu, click "New". The window "New synoptic" will then be displayed.
Click on OK to access your project.

3 In the "Draw" menu create a rectangle.

4 Select the rectangle that is created and go to the "Animation" menu, "Color", then
"Bar chart".

5 The "Draw" and "Aspect" tabs are used to define the object.

6 Select the "Bar chart" tab and click on the arrow of the drop down list in the
"Measure" window.

7 Click on the button in the "Clusters" window, select your alias and your variable
(giving the level) to be associated with the Bar chart, then validate. The Bar chart is
created and defined.

8 Click the "Mode" menu, then "Execution". We are now in execution mode, and the
bar chart shows the level of the tank.

Step Action

1 In the "File" menu, click "New". The window "New synoptic" will then be displayed.
Give a name to your synoptic, then validate

2 In the "Draw" menu, click on text and write a character string.

3 Select the text then go to the "Animation" menu, "Text", then click "Measurement of
states".

4 The "Draw" and "Aspect" tabs are used to define the object.

5 Select the "Display measurement of states" tab and click on the arrow of the drop
down list in the "Measure" window.

6 Click on the button in the "Clusters" window, select your alias and your variable
(giving the number of cars) to be associated with the text, then validate. The text is
defined.
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Perform the same procedure four times for this example.

To create a counter showing the total number of painted cars, proceed as follows:

Step Action

1 In the "Draw" menu, click on text and write a character string.

2 Select the text then go to the "Animation" menu, "Text", then click "Measurement of
states".

3 Select the "Display measurement of states" tab and write the formula giving the sum
of the four counters: " = Var1 +Var2 +Var3 +Var4" (for example) then validate. The
counter showing the total number of painted cars is created.

4 Click the "Mode" menu, then "Execution". We are now in execution mode. The
counter shows the total number of painted cars.
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Creating part of the "purification" synoptic

Description This demonstration project uses for the most part the "Status command", via the bits
and animation object "Color status groups". As for the "manufacturing demo", the
insert images tool is used to integrate the PLC photo.

Illustration of the example:

The tanks have been created by inserting an image, then superimposing an ellipse
("Draw" menu).

The tanks are distinguishable by their contents and their color:
� Tank 1: blue coloring,
� Tank 2: yellow coloring,
� Tank 3: red coloring.
� Tank 4: the coloring color depends on the status of the valves V1, V2 and V3.

Tank 1:
Tank 2:
Tank 3:

Tank 4:

Propeller speed

Value
Min.

Max.

Administrator 1 Purification station 11/10/01 13:54:17

11/10/2001 13:58:31 Alarm on - not ack Device1.Default01
11/10/2001 13:58:31 Alarm on - not ack Device1.Default01

Valve 1
Valve 2
Valve 3

Reservoir 1
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Creating an On/
Off button

Creating an On/Off button for the valve:

In this example therefore, three buttons must be created altogether.

Step Action

1 Before launching Vijeo Look:
� create an alias (give a name, and define the network type) in the OFS

configuration tool (see Reminder about editing aliases, p. 25), then validate,
� launch Vijeo Look

2 In the "File" menu, click "New". The window "New synoptic" will then be displayed.
Click on OK to access your synoptic.

3 In the "Draw" menu create a rectangle.

4 Select the created rectangle and go to the "Animation" menu, "Send", then
"Animated command".

5 The "Draw" and "Aspect" tabs are used to define the object.

6 Select the "Command status" tab and click on the arrow of the drop down list from
the "Status" window.

7 Click on the button in the "Cluster" window, select your alias and your bit type
variable (giving the valve status) to be associated with the "Command status",
then validate.

8 Select the "Colors status" tab, set up the colors of the button according to its status
and click on the arrow of the list from the "Status" window.

9 Click on the button in the "Cluster" window, select your alias and your bit type
variable (giving the valve status) to be associated with the "Colors status", then
validate. The animated Command is created and defined.

10 Click the "Mode" menu, then "Execution". Once in execution mode, one click on
the button should change the status and the color.
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The color of the coloring in "tank 4" and in "Reservoir 1" depends on the status of
the valves "V1, V2 and V3".
For example: if "V1" = 1, "V2" = 0 and "V3" = 0 then the color is blue.
Summary of possible combinations:

Status of V1 Status of V2 Status of V3 Color

0 0 0 -

0 0 1 Red

0 1 0 Yellow

0 1 1 Orange

1 0 0 Blue

1 0 1 Pink

1 1 0 Green

1 1 1 Light blue
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Creating a
"Grouped
status"

Changing the coloring color of "Reservoir 1" and "Tank 4" according to the status of
the valves (example whereby the coloring color appears in the drawing for "Tank 4"):

Step Action

1 In the "File" menu, click "New". The window "New synoptic" will then be
displayed. Click on OK to gain access to your synoptic.

2 Using the "Draw" menu create an Ellipse.

3 Select the ellipse, then go to the "Animation" menu, "Color", then click "Status
groups".
The following window appears:

Reading the color palette:
� read from left to right,
� associate the two leftmost figures with those next to the color,
� for example: pink = 01 & 01 = 0101.

4 The "Draw" and "Aspect" tabs are used to define the object.

5 Select the "Color status groups",

6 In the "Status of rank 0001" window, associate the variable of valve 1. Click on
the arrow from the drop down list.

7 Click on the button in the "Clusters" window, select your alias and variable
(giving the valve status) to be associated with the "Status of rank xxxx", then
validate. Do the same for "Status of rank 0010" and "Status of rank 0100". The
"Status groups" animation has been created and finalized.

Properties of the object

Draw Aspect Color status groups

Rank status 0001

Rank status 0010

Rank status 0100

Rank status 1000

V1%

V2%

V3%

Colors

Invalid status
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8 Tick the boxes of all the possible combinations and assign the corresponding
colors to these by clicking on the color window.
� If you wish to create pink, you must add blue and red. Which corresponds

to creating an "or" function between the status of V1, V2 and V3 for blue
and red, i.e.:
� status for the color blue: 0001

status for the color red: 0100
The result is: 0001 + 0100 = 0101 for the color pink. This value is used
to set up the colors in the diagram below.

Using the table described above that shows the color according to the status
of V1, V2 and V3, it is possible to set up all combinations.

9 Click the "Mode" menu, then "Execution". Execution mode is now activated. To
check that it is operating correctly, test the combinations of the table described
above.

Step Action
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Inserting an ActiveX and a Bean component

Example of
inserting an
ActiveX

Using an ActiveX (See Description of the main functions of the "Insert" menu, p. 22)
you can, by a simple click, create a link in your project to an HTML page, an internet
site, etc.

Description of the procedure to follow:

Step Action

1 Launch Vijeo Look

2 In the "File" menu, click "New". The "New synoptic" window will then be
displayed. Click OK to access your synoptic.

3 You are now in "Edit" mode. Pre-select the ActiveX controls in the Tools/
Ergonomics/ActiveX Control menu.

4 Click on the "Insert" menu, then "ActiveX Control ...". The ActiveX controls
present in this field are pre-selected.

5 Tick and select "Microsoft Web Browser", then validate.

6 Right-click on the ActiveX, then click on "Visualize script".

7 Type the following code (example of accessing the Schneider Automation
site):
Private Sub Mimic_Open
WebBrowser1.Navigate2 ("http://www.schneider-automation.com")
End Sub

8 Return to the Vijeo Look synoptic, maximize the ActiveX so as to view a
maximum of information, and save your project.

9 Click the "Mode" menu, then "Execution".

10 You are now in "Execution" mode: Internet should open and launch the
www.Schneider-Automation.com site

Note: You can, for example, create your own browser on the internet using the
tools offered in the ActiveX script. By right-clicking on the mouse, a list appears:
click on "List Properties/Methods". All of these tools can be used to develop in VBA
and create scripts for your applications.
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Example of
inserting a Bean
component

With Bean components (See Description of the main functions of the "Insert" menu,
p. 22) objects can be used to display numerical values by creating a link between
the variable and the Bean component.

Description of the procedure for displaying a numerical value via an analog device:

Step Action

1 Launch Vijeo Look

2 In the "File" menu, click "New". The "New synoptic" window will then be
displayed. Assign a name to your synoptic, then validate

3 You are now in "Edit" mode. Click on the "Insert" menu, then "Bean
Component".

4 Select "widgetsex.jar" then "com" then "schneiderautomation" then "widgets"
and finally, click on "MeterEx.class".

5 Select the Bean component inserted, then click on "List of Properties" in the
"Display" menu.

6 Click on "Variable Links", then on "input", and, finally, on the right-hand
drop down menu.

7 Click on the button of the "Clusters" window: the aliases created in the
configuration tool appear. Select your alias and choose the variable to be
associated with the Bean component.
You can, for example, associate the "Speed" variable from the "Helix1"
subdirectory of the alias "Waterplant".
Save your configuration. In the "Mode" menu, click on "Execution".

8 You are now in "Execution" mode, and the display pointer indicates the value
of the variable.

Note: When a Java Bean is used or inserted, the Java Runtime environment is
automatically launched.
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Writing a variable

Example using a
setpoint

Using the Send Setpoint command, it is possible to change the value of a variable
while remaining in execution mode.

Description of the procedure to follow:

Step Action

1 Launch Vijeo Look.

2 In the "File" menu, click "New". The "New synoptic" window will then be
displayed. Click OK to access your synoptic.

3 You are now in "Edit" mode. Click on the "Mode" menu, then on "Text".

4 Type a comment (only visible in "Edit" mode).

5 Select your text then go to the "Animation" menu, "Send", then "Setpoint".

6 Associate your variable in the space provided in the Measurement field by
clicking on the drop down menu, then on the button in the "Clusters" window.
Next, choose your alias and the variable associated with this alias.

7 Associate a comment with your variable (@ + text) and choose your send
mode (keyboard, etc.).

8 Click the "Mode" menu, then "Execution". You are now in execution mode, a
simple click on the variable will enable you to change the value using the
keyboard or another send mode.
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